My coding problem would be trying to follow the simple rule : less code is better.
This would make me try to squeeze way too much into a single line, everything in a single file.
You can imagine that more compressed does not necessarily mean less code but it certainly means less readable and less reusable.
I am trying to cure myself of this disease but there's certainly no quick way.
Keep telling yourself that readability is key, not compactness. Eventually your brain will re-learn.
Create a set of strict and exact rules you try to keep. F.i. two of mine are that classes declarations should have three blank lines between them and there is always two linefeeds above a scope keyword and one below.
Also, while not as quantifiable, try to enforce that only things logically belonging together should not have linefeeds between lines.
Try to keep things only of the same level of abstraction/granularity in the same function. This will mean you will start to compose more functions. This is OK, and good.
for (Food::iterator i = food.begin(); i != food.end(); ++i)
These rules introduced strictness, space and logical structure to your code and helps enormously with readability.