Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length

 
Advanced search

1044088 Posts in 42304 Topics- by 33983 Members - Latest Member: ChildrenOfMorta

September 20, 2014, 03:58:44 AM
TIGSource ForumsDeveloperTutorialsBlender Unwrapping
Pages: 1 [2]
Print
Author Topic: Blender Unwrapping  (Read 10991 times)
Kramlack
Guest
« Reply #20 on: December 11, 2011, 05:00:59 PM »

Using your version of the texture still gave the anti-aliasing effect.

EDIT: Or maybe not, hold on, apparently my eyes might have just tricked me. Gonna check it out further.
Logged
anonymous
Guest
« Reply #21 on: December 11, 2011, 05:02:07 PM »

wha wha --- I don't know any more
Logged
Kramlack
Guest
« Reply #22 on: December 11, 2011, 05:05:04 PM »

Updated the original post, I might be full of shit.

Follow-up: It indeed worked. I can't say I fully understand why the power of two thing is the only way to do it, but I won't question it at this point. Thanks Tor@noko!
« Last Edit: December 11, 2011, 05:10:23 PM by Kramlack » Logged
anonymous
Guest
« Reply #23 on: December 11, 2011, 05:49:40 PM »

I don't quite understand it myself but it's posted all here.  it has to do with technology and how they read things and blah blah boring
Logged
xrabohrok
Level 0
***


ahahahaAHAHAHAAHA


View Profile WWW Email
« Reply #24 on: December 11, 2011, 08:10:47 PM »

The power of two thing is for optimization.  In computer-lish, it uses the graphics card memory most efficiently, since everything is based off of twos.  It used to be the case that 3d cards would drop a texture not of a power of two dimmension like it was made of scorpions, and continue on as if nothing happened (creating an invisible object).  Some cards still do that (like my laptop, THAT was fun to figure out), but most things, like blender, take preventative measures by converting it into the next largest power of two.  If we were using just regular old box-projection mapping, instead of a UV unwrap, it would result in texture distortion.  But we are not, so it just adds some white stuff around the unused edges when it renders, and preserves the UV coordinates.  

The texture preview is going to be de-rezed in order to allow for smooth UI handling, there isn't much you can do about that.  In theory, you could double the texture's dimmensions in you favorite image browser, to try and compensate some.  But it is just the preview texture, don't lose sight at what is in hand...

*update = adding the 16 pixels to make 64 x 64 cleaned the texture up very nicely in the preview, but it still isn't crisp.  Good enough to know the end results, though.  



...This is the ideal end condition, when rendered.  I had to do nothing to the texture (still 48x64), it worked as is.  I had to turn off interpolation, like last time, but I also had to turn off pre-multiply.  Pre-multiply works like interpolation for alpha, and in this case it would add white edges to the box.  The checkbox is in the Texture tab, under where you specify the location of the texture (the "Image" section.  

Also, shoutout to SolarLune for alerting me to the UV snap-to-pixels feature, it was very useful for this.  

http://dl.dropbox.com/u/20581642/pixelCube.blend
Logged

A picture is worth a 1000 words, so naturally they save a lot of time.
anonymous
Guest
« Reply #25 on: December 11, 2011, 08:16:43 PM »

oh shisty snap-to-pixels I didn't know there was an option.  or pre-multiply.  thank you.  I think I understand things a bit better.
Logged
SolarLune
Level 10
*****


Hmm.


View Profile WWW Email
« Reply #26 on: December 11, 2011, 09:56:47 PM »

#xrabohrok - Thanks.

Snap-to-pixel is pretty useful. If you have a situation where you have a face over whole pixels (the way you want) but you see seams, you can turn off snap to pixels and size down individual UV islands (in the UV window, next to vertex and face selection) by a very small amount, like 0.95, to get rid of the seams and keep the same look. That's pretty much the only way I found to do it other than use a margin around the faces to ensure that the seams don't show up.
Logged

anonymous
Guest
« Reply #27 on: December 12, 2011, 02:55:24 PM »

Is there a way to render without lighting?  Like this:

No soft shadows.  This is a screenshot taken from game preview.
I'd like to render an animation to turn into gifs in this style, without having multiple sources of light to negate shadows.  [? ? ? don't know if that's clear.]
Logged
jotapeh
Level 10
*****



View Profile WWW Email
« Reply #28 on: December 12, 2011, 03:30:15 PM »

Tor@noko, just disable lighting in your shader? In Blender, go to the material panel and check "Shadeless"

That should do it. See my Santa in my workshop thread for the result you get from Blender (edit: here's a link so you don't have to hunt http://forums.tigsource.com/index.php?topic=16719.msg659351#msg659351 )

Unity will honor it too, if you choose unlit texture shaders.

Also check out I think Peter someone's Blender Low Poly Massive Tutorial http://www.youtube.com/watch?v=-P2o4M-hRgA

Check out Chapter 8 for textures specifically shading them (or rather not shading them)
Logged

anonymous
Guest
« Reply #29 on: December 12, 2011, 04:42:00 PM »

1000 dank u's
I saw those tutorials a couple months ago, didn't finish.  I like the music accompanying them.
Logged
Dragonmaw
Global Moderator
Level 10
******


Notorious D.R.G.


View Profile
« Reply #30 on: December 13, 2011, 12:11:03 PM »

A tutorial on how to UV unwrap well, as well as one on things like baking lightmaps and specular lighting, might also be useful. I might do that, IDK. There's a lot more to unwrapping than you might expect.
Logged

My religion consists of a humble admiration of the illimitable superior spirit who reveals himself in the slight details we are able to perceive with our frail and feeble mind.

-Snoop Dogg
ollie
Level 0
***



View Profile
« Reply #31 on: December 13, 2011, 01:26:33 PM »

Just started looking at Blender stuff and this tutorial was really helpful, thanks man  Hand Thumbs Up Right
Logged
xrabohrok
Level 0
***


ahahahaAHAHAHAAHA


View Profile WWW Email
« Reply #32 on: December 13, 2011, 04:25:40 PM »

A tutorial on how to UV unwrap well, as well as one on things like baking lightmaps and specular lighting, might also be useful. I might do that, IDK. There's a lot more to unwrapping than you might expect.

Yeah, I totally agree.  This tutorial is more of a "Where the heck are all the buttons?!" perspective, because that can be the hardest part sometimes.  I'm hesitant to do a UV slicing tutorial myself because the methodology is very situational and trial-and-error.  I'm still learning myself. Tongue

Just started looking at Blender stuff and this tutorial was really helpful, thanks man  Hand Thumbs Up Right
   Beer!
Logged

A picture is worth a 1000 words, so naturally they save a lot of time.
---
Level 10
*****


View Profile
« Reply #33 on: December 28, 2011, 10:01:42 PM »

I can't quite figure out how to make my texture apply to the material properly in Blender - I've loaded it as the material's texture, but in the render, it doesn't fold over the model, just loads as if I were applying it to the entire model.

Any advice?
Logged
SolarLune
Level 10
*****


Hmm.


View Profile WWW Email
« Reply #34 on: December 29, 2011, 04:38:41 PM »

Make sure that you've got the Map To property set to UV for the texture. It's in the Texture panel.
Logged

amijlee
Level 0
*


View Profile WWW Email
« Reply #35 on: March 04, 2013, 07:39:41 PM »

I followed the tutorial, but only two of the cube faces were textured. The other four were black. I tried moving the mesh around in the UV editor, but that didn't move the texture onto the black faces. What did I do wrong?
Logged
SolarLune
Level 10
*****


Hmm.


View Profile WWW Email
« Reply #36 on: March 05, 2013, 07:26:46 AM »

Make sure you've selected all faces, and then assign the material to the faces.

Also try selecting the faces and then selecting the correct image in the UV image window (to apply it to the faces).
Logged

amijlee
Level 0
*


View Profile WWW Email
« Reply #37 on: March 05, 2013, 09:07:22 PM »

Whoops, the black faces of the cube just weren't being lit.
Logged
Pages: 1 [2]
Print
Jump to:  

Theme orange-lt created by panic