Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length

 
Advanced search

1383496 Posts in 66147 Topics- by 58573 Members - Latest Member: PoteComPao

October 20, 2020, 06:24:18 PM

Need hosting? Check out Digital Ocean
(more details in this thread)
TIGSource ForumsCommunityDevLogsA Lode Runner Story
Pages: 1 [2]
Print
Author Topic: A Lode Runner Story  (Read 3884 times)
JobLeonard
Level 10
*****



View Profile
« Reply #20 on: March 07, 2015, 02:03:29 PM »

Sorry for missing this post, JobLeonard!  I have been very on again, off again with this project and completely missed it!


Also, I'm getting a black screen on my 1920x1080 Ubuntu laptop. Will try logging out and check if a Xubuntu session works better than Unity.
Logged
psyguy
Level 0
***



View Profile WWW
« Reply #21 on: June 25, 2015, 09:57:00 AM »

I've finally completed all principal development on this project.  From here, I will focus on ensuring the game runs properly for as many users as possible.  I updated the links in the original post, but I'll include them here as well.

Download v0.9.5 here:


Also, for JobLeonard:  I unfortunately have not been able to reproduce the black screen error on any of my local machines.  I did have a user report "slow performance" on a Unity install, but the game did launch and run on his machine.
Logged
psyguy
Level 0
***



View Profile WWW
« Reply #22 on: July 02, 2015, 01:26:22 PM »

I have a few GIFs of the game in action, finally!  (I should have been doing this all along, alas.)  They're a little bit on the large side, so I'll just put one in this post as an example.  I have the rest of them in an imgur album that you can also check out.



Link to full album:  http://imgur.com/a/StO4N
Logged
JobLeonard
Level 10
*****



View Profile
« Reply #23 on: July 03, 2015, 12:42:34 AM »

Aww yeah!

Downloading now, seeing if the problem is fixed. It could be because I have one of those laptops with both Intel and Nvidia graphics cards - it's been confusing other things as well.

Worst case I'll just reboot to Windows Tongue
Logged
JobLeonard
Level 10
*****



View Profile
« Reply #24 on: July 03, 2015, 04:47:48 AM »

Still all black window Shrug

I'll do some googling myself, see if there's an issue with Pygame on Linux.
Logged
psyguy
Level 0
***



View Profile WWW
« Reply #25 on: July 03, 2015, 07:38:27 AM »

Still all black window Shrug

That's tough to hear!  The game uses OpenGL for the graphics rendering.  Does that give you any lead on a setting or configuration on your machine that might make a difference?

My other thought right now is that the problem could involve the DLL files I import into the game that control the rendering.  Although I would expect the game to completely crash in the event of an incompatible DLL compile, I shouldn't rule it out completely.  I'll send you a quick PM, if you'd like to try compiling the DLLs on your local environment as an experiment.
Logged
JobLeonard
Level 10
*****



View Profile
« Reply #26 on: July 03, 2015, 07:57:30 AM »

DLL in Linux? Huh? Huh? You sure that's how it's supposed to work?
Logged
psyguy
Level 0
***



View Profile WWW
« Reply #27 on: July 03, 2015, 11:07:26 AM »

DLL in Linux? Huh? Huh? You sure that's how it's supposed to work?

I am spending a little bit of time to (hopefully) educate myself on this topic.  Apparently I've been creating "shared libraries" but simply using the .dll file extension (harmless if not ignorant, of course!).  I apologize for the confusion I created.  Smiley
Logged
Pages: 1 [2]
Print
Jump to:  

Theme orange-lt created by panic